Free Support Forum - aspose.com

Language formatting of dates

Hi there,

my system locale is English, but I have set the language of a date merge field in Word to be French unfortunately after merging the date is in English

With a MS <> field {DATE \@ "dddd, d. MMMM yyyy" \* MERGEFORMAT}giving DateTime.Today I get mardi, 3. juin 2008

With an Aspose MergeField though {MERGEFIELD QuoteDate \@ "dddd, d.. MMMM yyyy " \* MERGEFORMAT} I get Tuesday 3 June 2008

IE it seems to be ignoring the language of the field (even setting the language of the whole document it still converts to my system locale)

Cheers james

Hi

Thanks for your inquiry. Please see the following thread there was the same problem

<A href="</A></P> <P> </P> <P>I hope this coudl help you.</P> <P> </P> <P>Best regards.</P>

thanks Alexey

thats great! (I didn't find that post when searching the forums)

this will be an ideal solution

cheers james