Latest Version of Aspose jar support to JDK 8


#1

Hi Team,

We are using license version of Aspose family related jars from last 7 years.

Currently in Production we are using following jars with Version. Our application is running under Java 5.

Aspose Word .jar - Specification Version :- 10.1.0.0
Aspose email- 4.7.0.0
Aspose PDF jar - 2.7.0
Aspose-pdf-kit.ar - 3.7.0

Our client is doing the plan for upgrading java Version to 8 and along with all 3rd Parties jars to java 8.

Can you please provide the list of Jar names which will be support Java 8.

Thanks in Advance!!!

Regards,
R. Subramanum


#2

@Rsubramanum,

The latest versions of Aspose.Words for Java i.e. 18.9, Aspose.Email for Java i.e. 18.8 and Aspose.PDF for Java i.e. 18.8 all support Java 8. You may also please refer to the following pages:

Aspose.Words for Java - System Requirements
Aspose.Email for Java - System Requirements
Aspose.PDF for Java - System Requirements

Hope, this helps.


#3

Hi Hafeez,

Thanks for your Quick response.

I will verify jars and update to you.

Regards,
R. Subramanum


#4

Hi Team,

Please share the support version for aspose.word (Java) using Open JDK 1.8

Thanks & Regards,
Shyamala B


#5

@Shyamu,

Please note that the latest version of Aspose.Words for Java i.e. 19.8 supports Open JDK 1.8. You can download Aspose.Words for Java 19.8 from the following link:
https://downloads.aspose.com/words/java


#6

Thanks Awais !!

Please confirm as whether Aspose.words for Java 18.7 version will support Open JDK 1.8 or not

Thanks & Regards,
Shyamala B


#7

@Shyamu,

It should work but we do not recommend you use the old version of Aspose.Words for Java i.e. 18.7. Instead, please use the latest version i.e. 19.8.

P.S. Also, please note that we do not provide support for older released versions of Aspose.Words. We also do not provide any fixes or patches for old versions of Aspose APIs. All fixes and new features are always added into new versions of our APIs. So, please upgrade to the latest version i.e. 19.8. Hope, this helps.