libSkiaSharp version

We are getting this exception sometimes when we save (to PDF or TXT or DOCX):

Caused by System.InvalidOperationException: The version of the native libSkiaSharp library (80.2) is incompatible with this version of SkiaSharp. Supported versions of the native libSkiaSharp library are in the range [88.1, 89.0).

Would upgrading SkiaSharp.NativeAssets.Linux to latest 2.88.6 solve this? We are using 2.80.2 today.

@ResearchSquare Which version of Aspose.Words do you use? The latest version of Aspose.Words requires SkiaSharp 2.88.3 or newer. So SkiaSharp.NativeAssets.Linux 2.80.2 will not work with it.

We are using Aspose.Words 23.9.0 right now. I guess the question is if 2.80.2 is not compatible, should we bump it up to latest 2.88.6 or something in between? What’s most tested?

@ResearchSquare We have tested Aspose.Words with SkiaSharp 2.88.3. So I would recommend to use this version.

1 Like