Licensing issues for Aspose.Email


#1

I’m having troubles implementing the Aspose.Email license file for a web project. I am using the following code:

------------

Aspose.Email.License mLicense = new Aspose.Email.License(); string mPath = System.Web.HttpContext.Current.Server.MapPath( @"~/Aspose.Email.lic" );

try
{

mLicense.SetLicense( mPath );

}

catch( System.Exception er )

{

Console.WriteLine( er.Message );

};

------------

The file named Aspose.Email.lic is in the root of my web, and the mPath variable does return the correct location of the file. The product has been working correctly in Evaluation mode prior to the purchase and implementation of the license.

The Exception Message is:

“String was not recognized as a valid DateTime.”

Looking into the file itself, the only DateTime I find in the XML is “SubscriptionExpiry”, which has a value of “20060526”.

(I have also forwarded a copy of the license file via email.)


#2

Anyone home?


#3

Sorry for not replying earlier.

This is quite odd and we never get similar licensing error. Roman or Kyle will try to reply to you very soon.

FYI. Our products listed at your developer community portal www.developerfood.com have got good traffic. We really appreciate your efforts to promote our products. We will have Advertising Partners program that may save licensing costs when you need to acquire our products. Please check it out at http://www.aspose.com/Wiki/default.aspx/Aspose.Partners/HowToAdvertiseAsposeProducts.html. At this moment I’m writing it. Since now you’re urgent so I reply to you at first then I will contiune to write more. Please check it back.


#4

Ok, if Roman or Kyle need further information please let me know. I suspect that it’s an internationalization issue with date conversion of the SubscriptionExpiry value. The format YYYYMMDD may not be right for my US date/time settings.


#5

Sorry, not really. No USA customers got this error except you. I suspected your license file may be changed when you open it, but I immediately denied it since our license file can not be changed. If it’s changed, it will throw another exception message immediately.

Anyway, just hours later, when Kyle or Roman gets up, they will reply to you. Please be aware of they are living in China or New Zealand and at this moment, they’re sleeping. Smile Thanks for your understanding.


#6

Yes, I thought of it being corrupt as well. I later purposely changed the Expiry field to a more familiar datetime format and it gave me the exception about it not matching the signiture. I restored the original file and again received the previous datetime exception. Looks like it’s not a corrupted license file.


#7

Your license file seems correct since if it was edited - it would not match the digital signature and would be rejected straight away as corrupted.

The date time string in a file is supposed to be in yyyyMMdd format and our code reads it in exactly this format so regional settings are explicitly avoided.

I tend to think the problem is in Aspose.Email component itself, as it needs to have a special attribute set in AssemblyInfo.cs:

//This is used by Aspose licensing code to check for subscription expiry.
//You need to set this to the date you publish a release or a hotfix.
[assembly: AssemblyInformationalVersion(“2005.01.23”)]

So Kyle must double check Aspose.Email has that attribute and it has that in yyyy.MM.dd format exactly as shown (the date should be the release date of the component).


#8

Dear developerfood,

Could you please send me your license file and DLL? It could be great for troubleshoot, since your problem cannot reoccur here.

Thanks very much.

kyle


#9

Dear Sparky,

Sorry for any delays.

The problem is fixed in the latest hotfix version 1.1.6.

Thanks.

kyle


#10

The 1.1.6 version fixed it. Works now, and looks good.