Free Support Forum - aspose.com

Licensing problem with Nuget package

When I try to use the Aspose.PDF Nuget packages, I cannot use all of the packages that were created before the subscription expiry date. I can only use packages created up to 8 months before the subscription expiry date. Otherwise, the license check fails.

@wilsontimothy

Thank you for contacting support.

Would you please share a narrowed down sample application reproducing this issue along with your license file so that we may try to reproduce and investigate it in our environment.

Sure, is there an email I can send it to? I’d rather not post our license to the open forum.

@wilsontimothy

Please note any attachment over forum is accessible to thread owner and Aspose staff only. You may please send a private message by clicking on username. Please see attached screenshot for your kind reference.
private-message.png

Sorry, I didn’t know about the attachment security. I’ll create a solution now. FYI, I do not have the ability to private message, that may be a moderator-only ability.

Here is the solution. You will need to restore the nuget packages. One project fails, and one project runs successfully.
AsposePDFLicense.zip (17.8 KB)

@wilsontimothy

Thank you for sharing requested data.

Since you have recently sign up to Aspose forums so you did not have the privilege to send private messages to anyone. For your convenience, we have raised Trust Level for your account and hopefully you will be able to send messages to us for any future reference.

Regarding the problem you are currently facing, we are checking the details and will get back to you with our findings soon.

@wilsontimothy

We have logged a ticket with ID PDFNET-45151 in our issue management system for further investigations. The ticket ID has been linked with this thread so that you will receive notification as soon as the ticket is resolved.

We are sorry for the inconvenience.