We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Licensing problems on Aspose.Total (new downloads)

We have a license Aspose.Total License that is valid until August 4,2010 but are getting "Evaluation Copy" notices on PDFs we make using recently updated Aspose .dlls.

OUr license looks like this
<Product>Aspose.Total</Product>
<SubscriptionExpiry>20120804</SubscriptionExpiry>
<LicenseVersion>2.2</LicenseVersion>

Everything works fine on .dlls from August. But we get an "Evaluation Copy" on every pdf we make using newly downloaded .dlls (in this case Aspose.pdf).We are trying to use (downloaded and extracted from Aspose.Total_dll_only.zip)
Aspose.pdf.dll
File Version 6.5.0.0
Product Version 2011.12.01

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />If we use .dll downloaded last August everything works fine

Here is our Code
//Set aspose license
Aspose.Pdf.License license = new Aspose.Pdf.License();
license.SetLicense("Aspose.Total.lic");

Hello Charles,


Thanks for using our products. If you are using license as an embedded resource, please try using the following code snippet. In case the the problem is still not resolved, please share the license file so that we can test the scenario at our end. We apologize for your inconvenience. Please visit the following links for instructions on How to send a license?

// create a Pdf license object
Aspose.Pdf.License lic = new Aspose.Pdf.License();
lic.SetLicense(“MergedAPI.Aspose.Total.lic”);
lic.Embedded = true;

Where MergedAPI is the Default namespace of my project.

I sent you the license file as requested… Again we know how to use your product and set license files we have been doing it for years and successfully upgrading (in the past) by downloading new .dlls from your website.

It really should be as simple as changing the .dll in the /bin directory. Should’nt it!!! ???

For some reason we cannot use .dlls after August 2011 with the license file we have.

Charles

Hello Charles,


Thanks for sharing the license file. I have tested the scenario where I have created a project in VisualStudio 2010 ultimate with Target platform as .NET Framework 4.0 and as per my observations, when I have used Aspose.Pdf.dll (v6.5.0) present under net4.0 folder of Aspose.Total_dll_only.zip, the license is properly being honored. My application is running over Windows 7 professional X64 machine. I have also tried using the same license file as an embedded resource inside my project and I am also unable to notice any issue. Can you please share some code snippet/sample project which can help us replicating this issue at our end. We are really sorry for this inconvenience.

PS, In an other attempt, I have also changed the application Target framework to 3.5 and have tried using Aspose.Pdf.dll present under net3.5 folder and I am unable to notice any issue.