We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Log4j vulnerabilities

Hi

We are using following Aspose products. Can you please tell us if there is any vulnerability with log4j:
aspose.pdf-17.5
aspose.cells-21.2 (and 20.7)
aspose.email-17.8-jdk16
aspose.imaging-20.7-jdk16 (and 20.5)
aspose-word-17.8-jdk16

Regards,

@elie.kach,

Log4j library is not used in your mentioned Aspose for Java APIs. There is no such vulnerabilities in Aspose for Java libraries, the APIs do not have any built-in logging for it. In short, Aspose libraries (.NET/Java) are not affected by Log4j vulnerability CVE-2021-44228.

PS. We also recommend to use latest versions of the Aspose for Java libraries.