We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Mail Merge Font Problem

Version 4.4.3.0

I have a word template with merge fields in it and one of those merge fields has the PDF417 font applied to it. However when ever i merge the document the encoded data that was suppose to show up as a PDF417 font just displays the encoded data in regular font.

the sample codei am using:

//AbsolutePath as the path of the word document
Document doc = new Document(AbsolutePath);
// dsData.Tables[0] contains the data to be merged
doc.MailMerge.Execute(dsData.Tables[0]); 
doc.MailMerge.DeleteFields();
doc.Save("MergedDocument.doc", SaveFormat.Doc, SaveType.OpenInWord, this.Response);

I have also attached my word document

The Same thing happens when i apply a merge field with wingdings.

Hi

Thanks for your request. Could you please also attach simple template and font here for testing? I will check the issue on my side and provide you more information.

Also, please try using the latest version of Aspose.Words. You can download it from here:

https://downloads.aspose.com/words/net

Best regards.

I don’t think my subscription allows the new version,

However if this problem is solved with the new version then i will renew the subscription.

The template and files are attached to the post

Hi

Thank you for additional information. I cannot reproduce the problem with the latest version of Aspose.Words (8.0.0). I used the following simple code for testing:

// Open template.
Document doc = new Document(@"Test001\in.doc");
// Execute mail merge.
doc.MailMerge.Execute(new string[] {"First", "Last", "PDF417"}, new object[] {"Alexey", "Noskov", "1234567890"});
// Save output document.
doc.Save(@"Test001\out.doc");

Best regards.

Hey Alexey, the problem is solved on my end to with the version 6.0.1 You Emailed me

I would like to Thank you for your quick responses and Great Support!

Hi

I’m getting this same issue again with version 9.1 which I’ve just downloaded to try and fix another problem.

Can you please provide an update on this asap as I’ve got a project supposedly going live on Monday which relies on this feature.

Regards

Cliff

Hi Cliff,

Thanks for your request. I just checked one more time with the latest version of Aspose.Words and it seems all works fine on my side. Font remains unchanged after executing mail merge. Could you please attach your input and output documents here for testing? I will check once again with your inputs and provide you more information.

Best regards.