Mail send problem


I can not send mail !

Error: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
SMTP Server Settings
SMTP Server Address:
SSL: Enabled
Security Mode: Explicit

Email Message
Text Body:

or Error: Failure sending mail.

This work code fine

but asponce mail projects ( all ) not working please help

thank you

NetworkCredential loginInfo = new NetworkCredential(gmailAccount, password);

MailMessage msg = new MailMessage();

msg.From = new MailAddress(gmailAccount);

msg.To.Add(new MailAddress(gmailAccount));

msg.Subject = “konu”;

msg.Body = “mesaj”;

msg.IsBodyHtml = true;

SmtpClient client = new SmtpClient(“[](”);

client.EnableSsl = true;

client.UseDefaultCredentials = false;

client.Credentials = loginInfo;

client.Port = 587;



Thank you for evaluating Aspose products.

I have tested the below linked demos and I was able to send the test messages using my Gmail account.

[ ](

[ ](

Please try again.


hello I tested this address

[ ](

very nice work…

but my projecty not working …why ?

thank you

ı am using aspose.mail.demos2008

I am trying to local

[http://localhost:54438/smtp/Send-Email-SSL.aspx ](http://localhost:54438/smtp/Send-Email-SSL.aspx)

Does this problem ?


Attached to my reply is a test web application that you can execute on your end to verify the results. I have included the latest assembly of Aspose.Email for .NET v1.3.0 in the package. You only need to update the Username and Password in the web.config file because in this test application the credentials are picked from the configuration ().

hello thank you

I did everything but the problem continues.


This is very strange cause same project executed fine on my side and I was able to receive the email on its destination as well.

Please check out the technical article on how to enable POP access for your Gmail account. It can be the cause of your problem.

Please feed us back with your results.