We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

MailMessage.Load. 'ISO8859-15' is not a supported encoding name

Hi, we are using Aspose.Email.DLL version 2.9.0 and get the error:


System.ArgumentException: ‘ISO8859-15’ is not a supported encoding name.

when attempting to load a mail file which has Content-Type: text/html; charset=“ISO8859-15”.

I have tried with the latest version of Aspose.Email and the error no longer occurs.

Our license allows us to upgrade to versions up to January 2014, however the earliest version of Aspose.Email that is downloadable is version 5.0.0 from September 2015. Therefore I can not find out if this problem was fixed in a later version that our license allows.

Is our only option to upgrade to the latest version of Aspose.Email?

We currently have an Aspose Total license, do we have to upgrade to the latest Aspose Total? Or can we just upgrade the Aspose.Email component? What are the upgrade costs?

Thanks

Hi Jason,

Thank you for writing to Aspose Support team.

It is always better to upgrade to latest version of the API as it includes new features, enhancements and bug fixes that were present in previous versions of the API. You can upgrade your Aspose.Total license for latest versions of all the Aspose APIs, but if you want to upgrade only Aspose.Email, you can also do that by subscribing to this individual product. For details about the API upgrade cost, please post your query in Aspose.Purchase forum to get further details from our business team.

Regarding your concern for Jan 2014 version of the API, please note that versions older than one year are not available as per company policy. If you have any technical query related to the API, please feel free to write to us.

PS: Our documentations section, Migration from earlier versions of the API, lists all the changes that you will be in need of once you upgrade from version 2.9.0 to the latest version of the API.