Free Support Forum - aspose.com

Manual Install of Aspose.Words for Reporting Services on SQL 2008 R2 Server

I'm evaluating the .NET version of Aspose for RS,

Like many users I hit an error when trying to install onto a SQL Server 2008 R2 server. I tried the manual install procedure listed in the Aspose for RS documentation:

http://www.aspose.com/docs/display/wordsreportingservices/Installing+on+the+Server+Manually

In lieu of the paths to SQL Server 2008 I copied .dlls and updated configs under the SQL Server 2008 R2 folder paths but it didn't work...

Questions:

  1. Should the 2008 procedure work for 2008 R2 - if I copy the .dlls and modify configs under R2? Or is there a different procedure for R2?
  2. Do I need to register Aspose.Words.ReportingServices.dll in the GAC?
  3. Do I need to restart any services? (I restarted the machine and it didn't work)
  4. I'm installing v3.7.0.0 of Aspose.Words.ReportingServices.dll. Step #4 of the manual install instructions modifies a .config file and inserts a tag containing a PublicKeyBlob, is it possible the key has changed and I need a different key?
  5. Also in step #4 the Name="Aspose.Words_for_Reporting_Services" tag is not spelled the same as the Aspose.Words.ReportingServices.dll name, is this an issue? - I would the name should not matter, it should be driven off of the key - yes?

Any help is appreciated....

Hi,


Thanks for your inquiry. We are working over your query and will update you asap.

Nevermind I fixed it - I had copied the ReportingServices.dll into the wrong bin folder…

Hi,


Thanks for your feedback. The manual installation procedure is same for both SQL Server 2008 and SQL Server 2008 R2.

Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.

I fixed it - see my post above…

Hi,


Thanks for your feedback. It is nice to hear from you that you have solved your problem. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.