We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Maven dependency in Eclipse

Hi, I just upgraded to the latest version of Eclipse Version: 2019-09 R (4.13.0) Build id: 20190917-1200 as well as the 19.5 version of Aspose Cells. I’m trying to learn Maven and decided to do a quick test program adding a cells dependency to my POM file.

In Eclipse, I create a new Maven project and add the Cells dependency (see below) I get a red X on the POM file in my project explorer. When I remove the dependency the X goes away. Can someone please shed some light on what I’m doing wrong or if there’s possibly a server issue…?

The dependency in my POM.XML

com.aspose aspose-cells 19.5

My test code, the import for Worksheet is not found and is there an option to import it. Leading me to think that the POM isn’t working correctly…

package asposeTest;

public class AsposeTest {
public static void main(String[] args) {
Worksheet ws;
}
}

Also, I tried to add the Aspose Wizards for Eclipse/Maven and Eclipse non-Maven and saw the server was timing out when I tried to install new software in Eclipse.

Any help would be appreciated!

Thank you!
Perry

Sorry, I can seem to paste the XML from the POM to the forum… but basically it has three lines, a groupID of com.aspose, an artifact ID of aspose-cells and a version of 19.5.

@fischp,
You can download Aspose.Cells for Java Example project from GitHub and check the pom.xml file for reference. Please upload your project here if you face any issue.

Thank you, that worked! I appreciate the quick turnaround!

@fischp,

Good to know that your issue is sorted out by following the suggested pom.xml. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.