MaxRow - MaxColumn


#1

Hi,

I have a weird problem with embedding my created excel files into a ppt presentation. I found out that the embedded objects (my generated xls files) are scaled rather strange in my ppt file. This is because Microsoft PPT or XLS can’t find the borders of my excel.

In one case I have only a text value table that must be represented in the presentation. After generating the files, the object is very big, let’s say around 30 or 40 columns - although I have only two columns set. When I open the linked file (my generated xls), add a chart, remove it again, save the file and refresh the linked object the area in which data really is, is calculated correctly.

So could there be a possibility to set maximum row and column - or do you have an idea what’s up with my problem - let me know, i would really appreciate that

Thanks in advance

Michael Mann


#2

Dear Michael,

Actually I don’t clearly understand your problem.

1. Do you use Aspose.Excel to create the file or manually create it in MS Excel?
2. Could you send me your excel file and ppt presentation? Please use them to show me what’s wrong and what’s your expected result.

Thank you.


#3

Hi Laurence,

I use Aspose.Excel to create the files. Some background. I need to generate a complete report in ppt with lets say 50 pages. All of them represent charts or data tables stored in our database. What I do now is, I build excel files with charts and data, so that my users can change the data afterwards if needed. That’s why I need the excel files.

The problem with that is: each ppt slide has an embedded object - one of my generated excel sheets. When I open the ppt the embedded objects are not fitted to the size of my excel data and / or chart(s). correctly.

So I played around with a lot of settings and couldn’t find a way to fit it automatedly. The only thing I found out is, that when I open the embedded xls via double click, add a chart for the included data and remove that again, this object is fitted correctly. So my idea was, that I need to set a range or something else, that the excel range is fitted correctly.

Use my sample to get it:
- save the files in the same directory
- open the ppt
- double click the embedded object
- add a chart for the data in excel, remove it and close it with saving
- refresh embedded object in ppt
=> the result is the object is now fitted correctly

Maybe you have more deeper knowledge of what’s going on in the microsoft engine.

I sent the email with the files with the subject of this topic

Thanks
Michael Mann


#4

Hi,

sorry to bother you, but I found a workaround for that. This is indeed a weird effect of the Microsoft engine. While hiding all unnecessary rows and columns the object is as intended.

Michael