We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Missing referenced assemblies

Hi,

We’ve upgraded to V17.3, and it seems that the Aspose.PDF assembly is referencing
the following assemblies that I could not find (and were not required in previous versions):

Aspose.Foundation
Aspose.Font
aspose.Imaging4pdf
Aspose.JavaScript
Aspose.HTML
Aspose.ICC
Aspose.SVG
Aspose.Fixed2Float
Aspose.Builder.HTML
Aspose.CGM
Aspose.DOC
Aspose.XPSToAps
Aspose.Float2Fixed
Aspose.EPub
Aspose.PCL
Aspose.MHTML
Aspose.PptX
Aspose.HTMLOld
Aspose.XslFo
Aspose.CssOld



We are using the .net 4.0 version, but it is relevant for all .net editions versions of the Aspose.PDF assembly.
I also tried V17.4 and V17.2 - same issue.

Please help.

Thanks,

Oren.






Hi Oren,


Thanks for contacting support.

I have tested the scenario and have observed that Aspose.Pdf assembly is referencing to these assemblies. These are our internal assemblies/implementation. For the sake of correction, I have logged a ticket PDFNET-42538 in our issue tracking system. We will further look into the details and will keep you updated on the status of its resolution. Please be patient and spare us little time. We are sorry for this inconvenience.

Best Regards,


Hi, Is this issue resolved now?

@youranwj

Thank you for contacting support.

Would you please try to install Aspose.PDF for .NET 19.4 from NuGet gallery and you will not probably notice any issue of unresolved dependency with latest version. In case you face any problem then please share the details so that we may investigate further to help you out.

@youranwj

Adding more to comments by @Farhan.Raza, these are internal components of the API and merged with our code. However, if you are facing any issue during obfuscation, please share some details about your process and obfuscation tool you are using. We will further check it accordingly. The earlier logged ticket is closed and resolved now.

Thanks! Latest version works.