Free Support Forum - aspose.com

MOD Excel formula calculation issue in Aspose.Cells

Hi,

I have an error with the MOD function when calculated using Aspose.Cells. This was fixed in the previouse version of the library, but seems to be broken in the current version.

MOD on it's own seem to be working, however, when used in an IF as follows:

=IF(MOD(B1,2)=0,1,0)

Excel returns the correct value, the Aspose.Excel does not.

Please could you take a look at this.

Thank You,

Mick

Hi Mick,

Which version are you using? Please try this attached version.

Thanks for your reply.

I tried the version you suggested. The problem is still in this version.

I have a test spreadsheet that applies the formula and puts the results into a Form. When tried through Aspose.Cells the result is always zero. When using the same formula through Excel, the result varies from 0 to 1 as expected.

My dialog juts allows you to input a value to be applied in the If..MOD formula in my post. The result is displayed in another textbox in the dialog.

I don't think I have any errors in my small bit of code, but will check again. I would appreciate it if you could also check this formula.

Regards,

Mick

Hi Mick,

Thank you. Based on your description I found the problem and fixed it. Please try this attached version.

Thank you, that works perfectly.

Mick