We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Modifications to Slicer object properties get lost or cause disappearance of Slicer object

Hi Team,

I would like to report 2 issues regarding Slicer objects in Cells. Here are some further details as well:

  • OS: Ubuntu 20.04, Windows Server 2019
  • Editor: MS Office 2016
  • Aspose Cells library version: 21.8.0 (latest)

I was trying to handle with Slicer objects in Excel, get and set its string properties. I attached a sample project that can demonstrate both issues, you can find input and output files as well in the zipped attachment.

  1. Issue
    When trying to set the alt text title and description of the Slicer object, the result seems correct printing it out to the console, however, the output file still contains the original texts, so they do not get updated upon saving the workbook.
    You can see in the sample project that I tried the same procedure in case of handling Slicer objects as Shapes, but the result was the same.
    You can check the result in the output files (shape_output.xlsx, slicer_output.xlsx) or create the outputs by running the attached application.
    I would be grateful if you could help with updating alt text title and description fields for slicers successfully.

  2. Issue
    If you enable setting the Slicer object’s Name property in the attached code (it is disabled and marked with a note now) and run the app again, you can see in the slicer_output.xlsx output file that the Slicer object disappear from the worksheet.
    I would apperciate your help with this issue too.

Thank you in advance!

Best regards,
Tamas Boldizsar

cells_slicers.zip (31.2 KB)

@tamas.boldizsar,

Please notice, I am able to reproduce your both mentioned issue(s) regarding slicer object using your template file and sample code snippet. I have logged a ticket with an id “CELLSNET-48998” for the problem. We will look into it soon.

Once we have an update on it, we will let you know.

1 Like

@Amjad_Sahi

Thank you very much!

@tamas.boldizsar,

You are welcome.

@tamas.boldizsar,

This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

1 Like

@Amjad_Sahi

Thank you very much! I appreciate your quick help and am looking forward to trying the fixed version!

@tamas.boldizsar,
Please try the latest fix 21.8.6.
Aspose.Cells21.8.6 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.8.6 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.8.6 For .NetStandard20.Zip (5.6 MB)

1 Like

@John.He

I can confirm that the fix worked for both issues. Thank you very much, I appreciate you quick help!

Is the fix going to be available in your 21.9.0 release maybe?

@tamas.boldizsar,
Thank you for the feedback and we are glad to know that issue is resolved. This fix will be part of our next regular release v21.9.

1 Like

The issues you have found earlier (filed as CELLSNET-48998) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao