We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

MS Word Resulting document: Cant spell check

Hi,

This is an existing issue (Issue 4599) and I would like to know if it has been resolved?
The other post dealing with this issue hasn’t been updated in a while, which is why I have created a new post.

Thanks,
Marius

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Unfortunately this issue is still unresolved. I will notify you as soon as it is fixed.

Best regards.

Hi Alexey,

I’ve seen this issue in a few threads and I was wondering if there is an update or ETA on this (as I am facing this issue as well).

Thanks,
Will

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. The issue is still unresolved. I can’t provide you reliable estimate at the moment. Please expect a reply before next hotfix (within 3-4 weeks)

Best regards.

Hey,

I have found a work around that worked for me, and I hope this helps everyone else who is having similar problems. Using the below code snippets i can spell check my resulting word document.

I found that when you do a reveal formmating in your resulting word document, the language for the text was not being set. And because the language is not set, word set the text to no proof. The code snippets below I find in the Aspose Documentation

When adding new text to a document before builder.Write i set the locale:
DocumentBuilder builder = new DocumentBuilder(document);
builder.Font.LocaleId = 2057;
builder.Font.LocaleIdBi = 2057;
builder.Write(“Some new text”);


And when loading an existing document (as a template before adding new text to it) I ran through all the runs in the document and set their Locale

document.GetChildNodes(NodeType.Run, true, true);
foreach (Run run in runs)
{
run.Font.LocaleId = 2057;
run.Font.LocaleIdBi = 2057;
}



Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for this information. It is nice that you found solution.

Best regards,

Alexey,

I was not able to get bbd_dev’s solution to work. I tried setting the locale of the docbuilder and the document templates, but it still did not spell check.

Any other tips? Or ETA on a solution?

Thanks,
Will

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. The issue is still unresolved. But solution suggested by Marius should work. How did you create the document? Could you please attach your document for testing?

Best regards.