We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Multi-tab sort order not saved

I am using Aspose to stamp a version number in the footer. When I do this to an excel file with multi-tab sorting the file loses the sorting.

Hi,


Thanks for sharing some details.

Could you create a simple console application (you may zip it prior attaching here) and provide us here to reproduce the issue on our end. Also, attach your template files (input, output Excel file(s)) and some screenshots to highlight the issue, this will help us really to evaluate your issue precisely to consequently figure it out soon.

Thank you.

I have attached a Visual Studio project, two excel files: MultiSort.xlsx and MultiSort-After.xlsx, and two screen shots highlighting the issue.


Thanks

Hi again,


Thank you for sharing the sample project and spreadsheets.

We have evaluated the presented scenario while using the latest version of Aspose.Cells for .NET 17.1.7, and we are able to notice the said problem, that is; the sort settings are lost after adding footer to the worksheet. We have raised this incident as CELLSNET-45090 in our bug tracking system for further investigation & correction. Please spare us little time to properly analyze the scenario and get back with updates in this regard.

Please note, your project archive includes your license file as well therefore we have made this thread Private so that no one other than Aspose team members and the thread owner could access the thread’s attachments. It is advised that you should remove the license file from the archive for security reasons.

Hello,


Is there any update to this or a way to track this bug? We are using this for a client and they cannot use it as of now with this issue.

Thanks,
Cary
Hi,

Thanks for your posting and using Aspose.Cells.

We are afraid there is no update for you at this moment regarding this issue. However, we have logged your comment in our database against this issue and requested the product team to provide some fix or ETA for this issue. Once there is some news for you, we will update you asap by posting in this thread.

Hi,


I have removed the project with the license. Can you please make this public again?

Thanks

Hi again,


Thank you for removing the project. We have made this thread Public again. Furthermore, we have resolved the problem logged earlier as CELLSNET-45090. The fix will be available with next release of the API which is due in couple of days.

Hi,

Thanks for using Aspose.Cells.

Please download and try the following latest fix

Aspose.Cells for .NET v17.1.8 (.NET 2.0) compiled in .NET Framework 2.0.
Aspose.Cells for .NET v17.1.8 (.NET 4.0) compiled in .NET Framework 4.0.

and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-45090) have been fixed in Aspose.Cells for .NET 17.2.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.