We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Need net4 assembly

now aspose only privider net2.0 assembly, although it can run in net4 runtime, but because it reference 2.0 library, so the computer should install two versions of net framework, it is really inconveniently, in win8 the net2 is not install in default, and this will increase the app’s memory cost. is’t it?


can you please privider net4.0 assembly?

Hi Pyntia,


Thanks for your inquiry. You can confidently use Aspose.Words component with .NET Framework 4.0. There is no need to install .NET framework 2.0 at Windows 8. Please use the Aspose.Words.dll from net2.0 folder.
This folder contains the assemblies to use with .NET Framework 2.0,
3.0, 3.5, 4.0 and 4.5.

Moreover, we had already logged a request regarding
dedicated DLL for .NET Framework 4.0 as a new feature request in our
issue tracking system with ID WORDSNET-5394. I have linked this
forum thread to the same feature and you will be notified via this forum
thread once this feature is available.

We apologies for your inconvenience.

hi, Tahir


thank you for your reply

i use reflector to see aspose’s reference assembly, all of net framework dll’s version is 2.0.0.0, please look the below picture:

reference assembly version

if in a clean computer which does not install framework 2.0, i don’t think it can run properly.

Hi Pyntia,


Thanks for your inquiry. I have tested the Aspose.Words DLL from net2.0 folder with .NET Framework 4.0 at Windows 8 and have not found any issue. You can confidently use Aspose.Words component with .NET Framework 4.0. Please use the DLL from net2.0 folder with .NET Framework 4.0. Let us know if you face any issue.

The issues you have found earlier (filed as WORDSNET-5394) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)