We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Need urgent hot fix for Aspose.Cells 7.4.2.4 for Pivot Table lost issue

Hi,

We are currently using Aspose.Cells v7.4.2.4 with Office 2007.

We have a *.xlsm worksheet that has a pivot table inside. After opening the file and saving it the Aspose call “workbook.Save(…)”, the pivot table gets turned into plain cells (no longer a pivot table). (This issue does not occur with Office 2010)

We tested the subsequent Aspose.Cells versions and see that this issue was fixed between v7.4.3.1 and v7.4.3.2.

We urgently require a hot fix ON TOP of Aspose.Cells v7.4.2.4, is it possible to branch out v7.4.2.4 and only add the pivot table fix and provide it to us?

Regards,
Ann

Hi,

Thanks for your posting and using Aspose.Cells.

Please download and try the latest version Aspose.Cells
for .NET v7.5.2.2
and see if it works fine.

We provide fixes based on latest versions only. If your issue still occurs, please provide us your source xlsm file and sample code replicating this issue with the latest version.

We will look into your issue and help you asap.

Hi,

As previously mentioned, we are well aware of the fact that the fix has been in place since v7.4.3.2 and is also is in the latest v7.5.2.2.

What we NEED is this specific fix on top of v7.4.2.4 ONLY.

Can you consult your development / management team to see if this is feasible? We need this hot fix ASAP. If required we can promote this into a Enterprise Support item. Please let us know.

Thanks,
Ann

Hi,


We are very sorry but as my fellow colleague told you that the fixes are only based on the latest version of the product. I am afraid, we cannot include any enhancements or fixes in the older versions of the product. So, I am afraid, you have to use latest version(s) of the product.

Thanks for your understanding!

Hi,

Would the answer be different if I promote this issue onto Enterprise Support?

Regards,
Ann

Hi,


I am afraid, this won’t make any difference. Well, it is our internal policy to not to include any fixes to the older versions of the product, we have to follow our policy after all.

By the way, why you are persisting with your older version of the product e.g. .v7.4.2.x? We recommend you to kindly upgrade to the latest versions of the product in which we enhanced existing features and included many fixes.

Thanks for your understanding and sorry for any inconvenience caused!