We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

.Net 3.5 Aspose.Email bad characters

Hi I am having an issue when reading and email .msg file using the Aspose.Email DLL the read in HTML body has characters replaced lake the encoding is incorrect.

For example and ' char is replaced withFor example and ' char is replaced with ’

Opening the .msg file directly using outlook shows the email message correctly.

I am reading the .msg file in code as follows:

MailMessage existingMailMessage = new MailMessage();

existingMailMessage = MailMessage.Load(spFile.OpenBinaryStream(), MessageFormat.Msg);

Any help or suggestions would be appreciated.

Please see attached zipped email that is causing the problem.

Regards... Oz

Hi Ozhan,

Thank you for considering Aspose.Email as part of your solutions.

I was able to reproduce this issue at my end using the latest version of Aspose.Email for .NET 2.9.0 and have logged it in our bug tracking system under issue id: NETWORKNET-33781. Development team will look into it and once we have any information regarding the resolution of this issue, we'll update you here via this thread.

If you have any other query/inquiry regarding Aspose.Email, please feel free to post to us. We'll try to assist you further as soon as possible.

Hi Ozhan,


After checking the status of this issue from our issue tracking system, I would like to share with you that this issue is still in queue for analysis by the development team. We will update you here once there is any work around or other information available in this regard, and appreciate your cooperation in this regard.

The issues you have found earlier (filed as NETWORKNET-33781) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.