We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

.Net Aspose.Slides - After AddClone image size is getting reduced

Hi ,

I am using .Net based Aspose.Slide. I am creating slides dynamically and it has slides around 200 to 300 in numbers. I am having issue when I am trying to use AddClone method to add slide to existing presentation and it is reducing image size [compared to it is present in template ppt file].

Please find attached sample code to re-produce this. You can run this program and click on "Title Slide" button. This will create two slides in \bin\Debug\Templates directory.

Files listed in this directory as below.
TitleTemplate.pptx => This is template file i m using.
Test4.pptx => This file I am generating and saving it to file system [Without use of AddClone method]
Test3.pptx => This file I am generating and saving it to file system [With use of AddClone method]

I have issue with Test3.pptx generated with use of AddClone method. Image displayed on right side is getting reduced compared to Test4.pptx or TitleTemplate.pptx. In generally I am not setting any size or position of the image frame, but just replacing the picture value. You can see Test4.pptx has properly replaced image from template, but same when I tried using AddClone, it is reducing size.

Please let me know if I am doing any wrong step here.

This is little urgent as I have to deliver this code to customer over weekend and based on that they will be taking decision on purchasing full license for Aspose.Slides.

Regards,
Lalit

Hi Lalit,


I have worked with the code snippet shared by you. I have observed that the issue lies in the slide size for the two presentations. The template presentation has different slide size as compare to the default slide size when the presentation is instantiated. I have set the slide size and orientation. Please look for string “Mudassir” in the code and it you will see the modified code. Please share, if I may help you further in this regard.

Many Thanks,

Thanks Mudassir.

This has solved the issue.

Regards,
Lalit