Free Support Forum - aspose.com

.NET Framework 4.5 or 4.5.2

When getting the nuget packages for Aspose OCR I find that none of the build 19 versions are compatible with our code which targets .NET Frameworks 4.5 or 4.5.2 respectively.

The last version I’m able to use is a build 17

Would it be possible to have target frameworks such as 4.5 and 4.5.2 reintroduced in the next build 19?

@rozeboosje

Our new feature implementation, namely, Neural Network Player currently needs .NET Framework of version 4.6.2 and higher. Likely, it may be refactored and built under .NET Framework of version 4.0, but it requires some investigation. It will definitely be in the TODO-list for future releases.

1 Like

OR I could leverage this as a rationale for us upgrading our software :grin:

1 Like

Ok … So I changed all our projects in our solution - 40 in total - to use .NET Framework 4.6.2

While it all builds I now get the warning “Referenced assembly 'Aspose.OCR, Version=19.9.0, does not have a strong name”

Which fills me with dread because one of our applications is an Outlook Add-in in which we do intend to use this functionality. Our add-in MUST therefore have a strong name.

Can this please be addressed?

@rozeboosje

Sure, we will definitely address this issue as it has been logged as OCRNET-52 in our issue tracking system. We will further look into this and keep you posted with the status of its correction. Please be patient and spare us little time.

We are sorry for the inconvenience.

1 Like

Perfect ! thank you.