Free Support Forum - aspose.com

.NetCore 3.1 SetLicense

Hello, I just created a new .Net Core 3.1 project. I am attempting to set the .lic but an error occurs: “Could not load type ‘System.Runtime.Remoting.RemotingServices’ from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral…”. I have attempted to use set license as both a stream and string. This looks like a duplicate issue of SetLicense in .Net Core

I am currently using Aspose.PDF 20.6 and Aspose.Words 20.6.

Thanks,
Chris

I am not APOSE support; however, I had a similar issue.

Are you referencing the ASPOSE dll that is associated to the proper .NET version? APOSE provides several. If you are referencing the ASPOSE 4.0 version on a .NET 3.1 project I believe you will receive an error like this.

@cmlofal Awesome! That looks to be the issue, I tried several before one worked. The “netstandard2.0” dll does not give that error.

Thanks for the help!

@cfavNQ,
It seems that your issue is resolved and feel free to write us back if you have any other query related to Aspose.Total products.