Free Support Forum - aspose.com

New testing file for pivot table refreshing issue

HiI have attached an new Excel file for you to test the new pivot refreshing issues.

I raised a similar issue in this post previously http://www.aspose.com/community/forums/1/431618/error-refreshing-pivot-table/showthread.aspx

Thx for fixing the issue in the previous issue, but we just find another pivot table file failed the test with latest v7.3.4.3.

The repro code is :

string filePath = @"F:\Shak-Data-RW\Downloads\Pivot+Table+with+filter.xlsm";

Workbook sourceworkbook = new Workbook(filePath);

foreach (Aspose.Cells.Worksheet worksheet in sourceworkbook.Worksheets) {

foreach (Aspose.Cells.Pivot.PivotTable pivotTable in worksheet.PivotTables) {

pivotTable.RefreshData();

pivotTable.CalculateData();

}

}

Could you give us an approximate ETA once you guys have a chance to look at this one, please?

Regards

Bill

Hi,

Thanks for your posting and using Aspose.Cells.

We were able to replicate your mentioned issue: Aspose.Cells
for .NET v7.3.4.3
with the given code.

We have logged this issue in our database. We will look into this issue and fix it. Once the issue is fixed or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41256.

C#


string filePath = @“F:\Shak-Data-RW\Downloads\Refresh+Pivot+Table+Example-3.xlsm”;


Workbook sourceworkbook = new Workbook(filePath);


foreach (Aspose.Cells.Worksheet worksheet in sourceworkbook.Worksheets)

{

foreach (Aspose.Cells.Pivot.PivotTable pivotTable in worksheet.PivotTables)

{

pivotTable.RefreshData();

pivotTable.CalculateData();


}//foreach

}//foreach



Exception:

An unhandled exception of type ‘System.NullReferenceException’ occurred in Aspose.Cells.dll


Additional information: Object reference not set to an instance of an object.

Hi,

We have fixed this issue.

Please download and try this fix: Aspose.Cells for .NET v7.3.4.5 and let us know your feedback.

Hi Shakeel

Thanks for fixing our pivot issue again! I tried it and it worked perfectly.

Thanks again and wish you guys all have a good holiday!

Regards

Bill

Hi,

Thanks for sharing your comments and feedback.

We are pleased to know, this issue is also fixed now. Please feel free to post if you found any other error.

We will be glad to help you further. Enjoy the holidays. :slight_smile:

The issues you have found earlier (filed as CELLSNET-41256) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Yes, for Windows it works, but for Mono still crashes. See

http://www.aspose.com/community/forums/451091/mono-problem/showthread.aspx#451091

Hi Pavel,


Please check and followup the other thread, also, I have replied you in the thread there:
https://forum.aspose.com/t/97001

Thank you.