‘No Bullets or Numbering’ setting in the imported linked style ie to ‘inherit’ Bullets and numbering from the ‘based on’ parent styles’


#1

I also am attempting up update the look and Feel of documents created with an earlier version of template. Both the old and the new templates contain multilevel numbered list linked styles and both work fine on their own.

When importing the styles from the new template in an attempt to update existing documents Look and Feel, using organiser, the linked styles have no numbering. When looking at the linked style definition after import, ‘No Bullets and Numbering’ is evident. I can find no reason this might be happening. It is as if the import is causing a problem. (Although it might be something I have done).

Both templates use the same style names and I don’t know how to reset the ‘No Bullets or numbering’ setting on the imported styles without 'reverting to the parent (heading) styles (Heading 1 though Heading 9) ie deleting the styles and recreating them manually on each document to be updated.

Is there a way to tell Word 2010 to remove the ‘No Bullets or Numbering’ setting in the imported linked style ie to ‘inherit’ Bullets and numbering from the ‘based on’ parent styles’ . The numbering used is complex and requires multilevel linked styles.


Numbered list styles are not being imported correctly when using the KeepSourceFormatting import mode
#2

@Smith_Clarkson,

Thanks for your inquiry. To ensure a timely and accurate response, please ZIP and attach the following resources here for testing:

  • Your simplified input Word document(s)
  • Aspose.Words 19.10 generated output DOCX file showing the undesired behavior
  • Your expected DOCX Word document showing the correct output. You can create expected document by using MS Word.
  • Please also create a standalone simple console application (source code without compilation errors) that helps us to reproduce your current problem on our end and attach it here for testing. Please do not include Aspose.Words.dll files in it to reduce the file size.

As soon as you get these pieces of information ready, we will start investigation into your issue and provide you more information. Thanks for your cooperation.