We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

No imange in PDF created from excel file by Aspose.Cells on Azure

Hello,

We are using Aspose.Cells 21.8.0 licensed version on Azure, and have a problem in excel to pdf conversion function. Images on excel file are lost on the created pdf file. Please let us know how to solve it. Thanks in advance.

TQ-004_original.zip (8.3 MB)
TQ-004_21.8.0_generated_on_Azure.pdf (71.6 KB)
TQ-004_21.8.0_generated_on_Windows.pdf (2.2 MB)

@TomonariNakamura,
We have tried this scenario in Azure function but could not observe it with the latest version Aspose.Cells for .NET 21.9. Please give it a try with the latest version and share your feedback. If issue is not resolved, share a complete solution along with the environment details. Here is the Azure Http trigger function output.
output.pdf (280.1 KB)

Unfortunately, It happens on Cells 21.9. Here is the source code.
Program.zip (783 Bytes)
Let us know which kind of information you need about Azure.

@TomonariNakamura,
It seems that graphics libraries are missing in your environment. You may please try to install libgdiplus as follows and share your feedback:

apt-get update
apt-get install -y libgdiplus
cd /usr/lib && ln -s libgdiplus.so gdiplus.dll

And install libc6-dev:

apt-get install -y --no-install-recommends libc6-dev

Hello Ashan,

Thank you for your advise. But this seems an install method on Linux. We need it on Azure using .NET Framework 4.8. Thanks in advance.

@TomonariNakamura,
We have tried to reproduce this issue here however still not succeeded. This issue is logged into our database for a detailed analysis. You will be notified here once any update is ready for sharing.

This issue is logged as:
CELLSNET-49196 - No image in PDF that is converted from excel file by Aspose.Cells on Azure

Hi @TomonariNakamura
We reproduced the problem, and the test environment was:

Asp.net Web Application (C#), ,net Framework 4.8.
Deploy to Azure platform.

Please try the following setup at the beginning of the project:

Aspose.Cells.CellsHelper.IsCloudPlatform = true;

In my test environment, this setting can solve the problem.
Please let us know your feedback. Thank you.