We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

OCR Engine Created - No text imported

Hi
I use an application Windev and loaded the OCR Engine but no text is extracted. I don’t receive any errors.

Using .NET v4

pclOcrEngine is OcrEngine dynamic
pclOcrEngine = new OcrEngine
pclOcrEngine.ClearNotifies()
pclOcrEngine.Config.ClearRecognitionBlocks()
pclOcrEngine.Config.DetectTextRegions = True
pclOcrEngine.Config.ProcessColoredBackground = True
pclOcrEngine.Config.AddRecognitionBlock(RecognitionBlock.CreateTextBlock(361, 372, 330, 69))
pclOcrEngine.Image = ImageStream.FromFile(“D:\Google Drive\ScanSnap\untitled004.jpg”)
IF pclOcrEngine.Process() = True THEN
EDT_Text1 = pclOcrEngine.text
ELSE
EDT_Text1 = “Nothing was done.”
END

No error is created but no text are returned. I have tried the same above without the RecognitionBlock but same result.

@let-1,

Please share your input file with us. We will try to reproduce the issue at our end and will share our findings with you in this forum thread.

Here is the file I am working with.

untitled004.jpg (845.2 KB)

Thanks for your assistance

@let-1,

We have evaluated the sample image shared by you. The image has colored background. At the moment, Aspose.OCR has some issues with colorful backgrounds. The issues have already been logged into our issue tracking system with ID OCRNET-1053. Our developers are working on these issues. We will update you with the progress via this forum thread.

We are sorry for the inconvenience.