Free Support Forum - aspose.com

OCR is broken

Running the demo gives me


answer -> abcdefgnij

part.getText() => abcdefgnij

… and that’s using the Sample.bmp and running demo.bat file from the samples folder! If this worked correctly, we should have multiple parts consisting of the whole alphabet-- upper and lower case, numeric, and some non-numeric values, right?

What is going on?

Hi Chris,

Thanks for your inquiry. There is a limit of ten character recognition on evaluation version of Aspose.OCR for Java API, so that's why you are unable to recognize complete text. If you want to test Aspose.OCR for java without evaluation version limitations, you can request a 30 day temporary license here. <?XML:NAMESPACE PREFIX = O />

Please feel free to contact us for any further assistance.

Best Regards,

Got the license… New output:



answer -> abcdefgnijkImnopqrstuvwxyz
ABCDEFGH IJKLMNOPQRSTUVWXYZ
01 23450789
-!1-+!()

part.getText() => abcdefgnijkImnopqrstuvwxyz


part.getText() => ABCDEFGH

part.getText() => IJKLMNOPQRSTUVWXYZ


part.getText() => 01

part.getText() => 23450789


part.getText() => -!1-+!()

Still not great and so slow!

And, when trying to use it for ALPR, it’s a complete fail. Am I doing something wrong?

Hi Chris,


Thanks for your feedback. Sorry for the inconvenience, our development team is working over a major revamp of Aspose.OCR API for performance improvement, support of smaller font sizes, new fonts and languages.


Secondly, Please share some more details regarding reading ALPR. Can you please also share some sample image? So we will look into and share more information accordingly,

Please feel free to contact us for any further assistance.

Best Regards,