We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Old Linux Support for PDF Processing

My company would like to run your pdf library under an old version of Linux, like Fedora 19 from the year 2013, running kernel 3.10. Do you support such old versions of Linux? If not, how far back do you go? Which of your libraries would you suggest we try (we prefer c++, but could probably use java or .net if you support those).

Thanks!

@dev71243

Thank you for contacting support.

We are checking the details and will share the details with you soon.

@dev71243

Thanks for your patience.

Please note that as far as .NET Core 2.0 can be installed in Linux system, you can run Aspose.PDF for .NET there without any issue. However, you may need to install following:

  1. libgdiplus package
  2. package with Microsoft compatible fonts: ttf-mscorefonts-installer. (e.g. sudo apt-get install ttf-mscorefonts-installer )

These fonts should be placed in “/usr/share/fonts/truetype/msttcorefonts” directory as Aspose.PDF for .NET scans this folder on Linux like operating systems. In case operating system has other default folder/directory for fonts, you should use following line of code before performing any operation using Aspose.PDF.

Aspose.Pdf.Text.FontRepository.Sources.Add( new FolderFontSource( "<user's path to ms fonts>" ));

Furthermore, Aspose.PDF for Java Library should also work in the this environment without any issue but we need to further test it. We will further let you know as soon as we have further information in this regard.

As far as Aspose.PDF for C++ is concerned, we do not build this API for any UNIX system yet. However, we do have plans in future to add support for this. For old Linux Version(s), there are following conditions which need to be fulfilled;

a) Need C++ compiler gcc6 or clang3.9
b) Third party libraries (ICU, Boost, Botan, libxml and few more) should support the OS kernel version

You can have difficulties with the second condition. For example, if ICU library does not support Fedora 19 then our API does not support too. We hope this information will be helpful for you. In case you need further assistance, please let us know.