We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

One of our word documents doesn't load

For most reports that I load using the Aspose.Words.dll, I don't have any problems. The last couple of days, I have been running into a problem with loading a specific report and can't figure out why, but I get an error indicating the document is corrupt. I can open the report using word w/o issue. Below is the code that I use. The last line is where the error occurs.

oLic = New Aspose.Words.License
oLic.SetLicense("C:\Projects\SMA v2010\SMA_vs2010\Aspose.Words.lic")

'Open the template document
oDoc = New Aspose.Words.Document(szFile)

I have attached the word document that I am having a problem with. The version of your product I am using is 2008.05.15. Can you please let me know either how the document can be fixed or if there is something I can change in code.

Thank you

Dave

Hi Dave,

Thanks for your request. I cannot reproduce the problem on my side. I used the latest version of Aspose.Words for testing. You can download the latest version from here:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

Best regards,

Can you try with the product version I am using. I tried with the latest version and I get an error saying that my license subscription has expired. If we decide to upgrade our license, I would like it confirmed that you have the same error with the product version I am using and then it was fixed by using the latest version

Thank you.

Hi Dave,

Thanks for your request. I check the document with Aspose.Words 5.0.2 and I do confirm that exception occurs upon loading your document.

If you want to test new version of Aspose.Words without the evaluation version limitations before renewing your license, you can request a 30-day Temporary License. Please refer to

http://www.aspose.com/corporate/purchase/faqs/temporary-license.aspx

Best regards,