Free Support Forum - aspose.com

Online converter produces a clean result while code provides corrupted file

I007839-20.pdf (116.9 KB)

Online converter can convert the file to xlsx correctly, but when I use the following code sample it only produces corrupted file.

	Document doc = new Document(file.getPath());
		ExcelSaveOptions options = new ExcelSaveOptions();
		options.setInsertBlankColumnAtFirst(false);
		options.setMinimizeTheNumberOfWorksheets(true);
		options.setScaleFactor(0.9);
		options.setUniformWorksheets(false);
		options.setFormat(ExcelSaveOptions.ExcelFormat.XLSX);
		doc.save(file.getPath(), options);

@canangunicen,

Thanks for contacting support.

We have tested this scenario in our environment and have been able to observe the issue that you have mentioned. We have logged issue with ID PDFJAVA-39468 in our issue tracking system. We will share with you as soon as logged issue is fixed.

I am having this issue with Java. The ticket id looks like it is for .NET.

@canangunicen,

I have updated ticket to Java. We will share good news with you soon.

How long does it take for you to solve this issue, if we switch to paid support because we really need this for our implementation.

@canangunicen

We need to investigate the ticket in detail in order to share some ETA. However, we have recorded your concerns and will surely perform analysis. We will let you know the ETA as soon as the ticket is fully investigated. Please spare us little time.

@canangunicen

Would you kindly check attached output XLSX file which was generated using Aspose.PDF for Java 20.6. Please note that we have improved the conversion engine in latest release of the API and results look better than before. There are less serious issues except a line with “Circuit ID” text “Commencement Date” cell also shifted. We will try to fix it in next release of the API. However, please let us know in case you see any other issue in the output.

output.zip (5.1 KB)

Unfortunately, I tried the file I provided to you, and its output corrupted again.

Hi again are you using the code above, because with it I cannot get the result you have.

@canangunicen

Would you please try using the latest version i.e. Aspose.PDF for Java 20.6. Also, please share some screenshot of the error that you are facing while opening the file as if it is corrupted. We tested the scenario in our environment and output file was fine.

Hi again, I am using the latest version. I do not get any error during conversion but I will attached the output file. It is not opened by excel, and it cannot be read through Aspose.Cell API too.

jamaica.xlsx.zip (2.1 KB)

Screen Shot 2020-06-30 at 13.10.50.png (27.4 KB)
Screen Shot 2020-06-30 at 12.29.05.png (16.4 KB)

@canangunicen

We were also unable to open the document shared by you. Whereas, we did not face any issue while converting and opening your files in our environment. Would you kindly make sure to test PDF to XLSX conversion in a standalone Console Application. In case issue still persists, please share the same application with us. We will again test the scenario in our environment and address it accordingly. Also, please try to use Class names with namespaces e.g.:

com.aspose.pdf.ExcelSaveOptions

When I do with a standalone app it worked and I saw that it is a Locale issue. Now it works on my application. But I opened another ticket like following:

When I updated 20.6, it started to convert only footers like in the screenshot:

Screen Shot 2020-07-01 at 13.34.14.png (242.4 KB)

Original file is:

18188.pdf (168.6 KB)

It was converted like this before:

Screen Shot 2020-05-29 at 12.50.57.png (241.6 KB)

And there was a cell alignment issue.

There are also lots of other problems in new version. My guess is it is possible that there is something problematic with setUniformWorksheets because this was the result with 20.5
And it is a structured data.

Screen Shot 2020-07-01 at 14.45.07.png (32.1 KB)

But with 20.6 this is what I get:

Screen Shot 2020-07-01 at 14.51.41.png (209.5 KB)

Completely messy, unstructured data.

If you want to try here is the original file:

90501162.pdf (91.8 KB)

@canangunicen

The other issue that you have referred is currently under investigation phase. We have logged adittional provided information along with the ticket and will surely consider it for investigation. We will inform you as soon as we have some updates in this regard. Please spare us some time.

I have mentioned other issue, because it is now converted into completely issue. Before there was an alignment issue, but now it does not convert the significant amount of pdf.

@canangunicen

We have noticed that there are some encoding related issues and all symbols in the output PDF are broken. We will surely investigate from this perspective and let you know as soon as we have some updates. Please spare us some time.

We are sorry for the inconvenience.

Please beware that these pdfs are processed correctly in version 20.5.

@canangunicen

Sure, we will keep that in view and investigate the logged ticket accordingly.

Dear Support Team,

Version 20.6 is not usable as described above and we are struggling to handle its unexpected behavior about previously working conversion cases. Can you please share an ETA on this issue?