We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Open vsd files gives "Error in element VisioDocument in \VisioDocument. Visio files with versions below 11 are not supported. Please convert the file to Visio 2003/2007/2010 format."

Please advise what is causing the error

“Error in element VisioDocument in \VisioDocument. Visio files with versions below 11 are not supported. Please convert the file to Visio 2003/2007/2010 format.” from

New Aspose.Diagram.Diagram(_DocumentPath)

for each of the 8 vsd files in the attached zip file.

Thanks for your attention

Hi Jeff,


Thank you for contacting support. I’m sorry to share with you that the Aspose.Diagram supports 2003 or higher versions of Visio. Please save your file in 2003 or higher VSD format and you will be able to easily render your diagram in all supported formats. A new feature request to support older Visio formats has already been logged into our issue tracking system as DIAGRAMNET-50279. We will keep you updated on this issue in this forum thread. We’re sorry for the inconvenience caused.