We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Opening and saving xlsm file with specific macros and ribbons throws away macros and ribbons

Our client has a specifically developed xlsm with a custom ribbon on top, which is launched by macros.

After going through Aspose with just opening and saving the xlsm workbook, the new ribbon has disappeared and a few of the macros don't seem to be present either.

Hi,

Thanks for your file. We will look into it and fix this problem asap and update you.

This issue has been logged as CELLSNET-40014.

Hi,

We have fixed this issue. Please download: Aspose.Cells for .NET v7.0.2.1

Thanks,

This seems to be quite a good fix. One issue however: in Office 2010 32-bit (on 64-bit the document doesn't work) it now shows an error when opening, but after saving everything is ok again. On Office 2007 no error is shown and the functionality still works, so that's great.

I've got to test a few others xlsm files with this version on Monday too.

Hi,

Thanks for your feedback and comments. We have added your feedback in our database. We will investigate this issue according to it and update you asap.

Hi,


After further investigation, we come to know when we opened the original file provided by you using Excel 2010, it also shows error, same as the output file generated by our product. So we think it’s not a issue.

Thank you.

The issues you have found earlier (filed as CELLSNET-40014) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.