We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF 1.4 detected as PDF 1.5 by Acrobat Reader

We encountered an issue with PDF 1.4 files. After resaving certain files (e.g. for linearization), the Acrobat Reader DC will detect the output to be of PDF version 1.5. Unfortunatly our customers complain about the version mismatch.

The following code reproduces the error:
Aspose.Pdf.Document doc = new Aspose.Pdf.Document(@“WC500222351_acrobat_1.4.pdf”);
doc.Save(@“WC500222351_acrobat_1.4-test.pdf”);

Note that the attached file originally was a PDF 1.5 file until it was resaved as 1.4 using Acrobat Pro.

Tested with Aspose PDF 11.0.0.0 and 12.0.0.0

Hi Stefan,


Thanks for contacting support.

I have tested the scenario and have managed to reproduce the same problem that your provided PDF file is not saving as 1.4. For the sake of correction, I have logged a ticket PDFNET-42519 in our issue tracking system. We will further look into the details of this problem and will keep you updated within this forum thread on the status of the resolution of this problem. Please be patient and spare us little time. We are sorry for the inconvenience.

Best Regards,

Is there any progress on this issue?

@Stefan.Schroth

Thanks for your inquiry.

I am afraid that earlier logged issue has not been yet resolved due to other pending issues in the queue and product team has been busy in resolving them. As soon as we have some significant updates regarding resolution of your issue, we will inform you. Please be patient and spare us little time.

We are sorry for the inconvenience.