PDF file does not convert to PDF/A-1A


I’m using Aspose PDF for Java v23.1
Trying to convert a .pdf file to PDF/A-1A format using below code:

document.convert(new ByteArrayOutputStream(), PdfFormat.PDF_A_1A, ConvertErrorAction.Delete);

No errors are thrown in the process however the resulting file does not conform with PDF/A-1A specification.
Original and converted files are attached.
Please advise.
Thank you

convertedPDF.pdf (127.1 KB)
originalPDF.pdf (111.4 KB)


Can you please share which tool are you using for testing the compliance? Can you please share the screenshot of the compliance test results? We will test the scenario in our environment and address it accordingly.


I’ve tried various online tools like:

I’ve also tried the ‘isPdfaCompliant()’ method availbale in ‘com.aspose.pdf.ADocument’, and it returns false.

image.png (9.3 KB)
image.png (25.9 KB)


We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): PDFJAVA-42562

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.

The same issue with Office365 Excel file exported into pdf.


We have updated the ticket information as per your feedback and will let you know once we have updates in this regard.