We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF not showing filtered items

Hi,


We seem to be unable to generate a PDF file from an excel file containing a pivot table filtered using value filters. It looks like items filtered using label filters appear correctly in the generated PDF but items filtered using a value filter doesn’t.

I have attached a small project that demonstrates this problem. When you run this project it opens file selected through an “Open File Dialog”, refreshes the file’s ListObjects and Pivot tables, then saves two files; a “generated file.pdf” and an “generated file.xlsx” file. The excel file contains the right pivot table, but the pdf file is incorrect when filtering using "Values Filters…"

Please run the application on the attached files.

“testFile.xlsx” contains a pivot table filtered using “Value Filters…

“testFile2.xlsx” contains a pivot table filtered using "Label Filters…"

When you run the project and select “testFile.xlsx” the generated PDF file’s pivot table has not been filter.
When you run the project and select “testFile2.xlsx” the generated PDF file’s pivot table has been filtered.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

After investigation, we found that pivot table with value filter does not generate correct pdf. We have logged this issue in our database. We will look into this issue and fix it. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41614

Hi,


While looking for a possible workaround, it seems that a second level row label doesn’t work properly when filtering against “(blank)” items.

I have attached a different excel file “testFile3.xlsx” that can also be opened using the project I have attached in this thread.

Hi,

Thanks for your further input.

We have attached the output documents for your reference.We have logged your comment in our database.We will look into it and once we will have some update relating to it, we will share it with you asap.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.3.2 and let us know your feedback.

Hi,


Thank you for the fix, filtered values seem to be working now.

Hi,

Thanks for your feedback.

We are pleased to know your issue is fixed with the latest version. If you encounter any other issue, please feel free to post on our forums, we will be glad to help you further.

The issues you have found earlier (filed as CELLSNET-41614) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.