Free Support Forum - aspose.com

PDF Output: Removing blank paragraphs after mail merge

I’m using mail merge for multiple rows. See the attached Template.doc file.


I’m then iterating through all nodes and deleting empty paragraphs to produce the expected output. See the attached CorrectFormat.docx file.

However, when I save as PDF, the formatting is messed up. See IncorrectFormat.pdf.

Is this a bug?


Thanks,
- J

Dear J,


Thank you for request.

Unfortunately I cannot reproduce reported by you issue using your template. May I have chance to look at your code you use to get .docx/.pdf file?

Thank you for cooperation.


Dear J,


Good news - It seems the problem you met is known and is under resolving by our development team. I have linked your request to related record in our tracking system. We will keep you updated.

Meantime there are 2 ways how to work around this: either leave empty paragraph between tables or merge tables in one. Here you can see code sample for these 2 ways.

Hope this helps.


The issues you have found earlier (filed as 9902) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

This feature is now available in this .NET update and in this Java update. You can now avoid empty paragraphs in repeating regions in this version by setting RemoveEmptyParagraphs to true.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(1)