We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF with error "The font '...' contains bad /Widths" from PPTX with special font using Aspose.Slides for .NET

Hi,

We are using Aspose.Slides for .NET version 17.7 for conversion PPTX files to PDF files and got an issue with special fonts. We are making PDF files using following code:

using (var presentation = new Presentation(inputStream))
{
    presentation.Save(outputStream, SaveFormat.Pdf);
}

Steps to reproduce:

Copy Samba.ttf and Asimov.otf from attached ZIP to C:\Windows\Fonts.
Take initial Fonts.pptx and generate PDF file from it.
Open resulting PDF file in Adobe Reader.

Expexted results: file is opening without any error messages.

Actual results: file is opening, but Adobe Reader show window with message: “The font ‘FAAACH+Asimov’ contains bad /Widths”.

If we open Fonts.pptx in MS PowerPoint 2013 in same environment ans save it as PDF, resulting PDF file is opening in Adobe Reader without error messages.

In attached ZIP archive:

Samba.ttf and Asimov.otf - fonts;
Fonts.pptx - initial PPTX file;
Fonts.pptx.pdf - resulting PDF file, generated by Aspose.Slides;
Error.png - screenshot, that demonstrates the issue.

Thanks,
Roman

Fonts.zip (391.1 KB)

@cap.aspose,

I have worked with presentation file shared by you using Aspose.Slides for .NET 17.10 and unable to observe the issue. I have also shared my generated result with you for your kind reference. Please check attachment. Can you please try to use Aspose.Slides latest version on your end and if there is still an issue than please share environment details so that we may further investigate to help you out.Fontsresult.pdf (56.3 KB)
Fontsresultwith17.7.pdf (56.3 KB)

Thank you for reply.

I downloaded Slides version 17.12.1 and repeated described scenario. The issue is reproduced with this version.

Looking at the files, shared by you, I assume that you did not install fonts from my ZIP. Fonts in my PDF and in your PDFs look are differently. Please open PDF from my ZIP and any of your generated PDFs in Acrobat Reader. Then click File -> Properies -> Fonts. In my PDF both fonts are present in the list, in your PDFs they are absent.

Please install both fonts from my ZIP and and generate PDF again.

Thanks,
Roman

@cap.aspose,

I have worked with the presentation file on my end and have been able to reproduce the issue. I have created an issue with ID SLIDESNET-39847 in our issue tracking system to further investigate and resolve the issue. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.

Hi,

I downloaded the latest version of Slides (18.12) and checked the issue described above. In this version of Slides the issue is still observed. Are there any updates on this issue?

Thanks,
Roman

@cap.aspose,

I have worked with source file and sample using Aspose.Slides 19.1 and unable to observe any issue. I have also shared my generated result with you for your kind reference. Please check attachment. Can you please try to use Aspose.Slides 19.1 on your end and share feedback with us if there is still an issue.39847-2.pdf (30.3 KB)

The issues you have found earlier (filed as SLIDESNET-39847) have been fixed in this update.