We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF/X conversion results in abnormal behavior

I’m using aspose pdf in our .NET app to convert pdf to pdf/x. But it converts to pdf/x4 which results in abnormal behavior (converts lines, borders and fonts from black to green color). I ran a preflight check on Adobe and it fails to conform to the proper rules. In Adobe, I changed to pdf/x3 and everything seems to work. I’m assuming this could be a bug or some setting that I’m not aware of. Any suggestions would be greatly appreciated.

@bh118657

Can you please share the below information with us?

  • input and output PDF documents
  • sample code snippet for conversion
  • screenshots of compliance results in Adobe Reader

Please also make sure to test the scenario with 22.2 version before sharing the requested information.

Thank you for replying. As suggested I updated version to 22.2 and it worked. Thanks again.

@bh118657

It is good to know that your issue has been resolved. Please feel free to create a new post in case you need further assistance.