Free Support Forum - aspose.com

PDFA conversion results in large file

Hello


We have a slight problem with the conversion from PDF to PDFA.

When we convert a file (attachted bellow) to PDFA, the file comes out way bigger than we believe it shoud (as we tried the same thing with Adobe PDFA converter, and the file is almost ten times smaller, also attached bellow).

I have tried some options to optimize this, the code I used:

Aspose.Pdf.Document pdfDocument = new Aspose.Pdf.Document(path_to_file);
var tst = new PdfFormatConversionOptions(PdfFormat.PDF_A_1B, ConvertErrorAction.Delete);
tst.IsLowMemoryMode = true;
pdfDocument.Convert(tst);
pdfDocument.OptimizeResources(new Aspose.Pdf.Document.OptimizationOptions() { RemoveUnusedStreams = true, RemoveUnusedObjects = true, LinkDuplcateStreams = true });
pdfDocument.Save(path_to_converted_file);

I will attach the outcomes (different combinations of options, shown above).

Can you help us fix this? Is there anything else I can use, to make the PDFA size smaller?

Kind regards,
Katja Suvajac

Hi Katja,


Thanks for contacting support.

I have tested the scenario and have managed to reproduce the issue that PDF to PDFA conversion for the attached PDF file generates large file size. For the sake of correction, I have logged a ticket PDFNET-42579 in our issue tracking system. We will further look into the details of this issue and will keep you updated on the status of its resolution within this forum thread. Please be patient and spare us little time.

We are sorry for this inconvenience.

Best Regards,

Hello,

just checking in, what is the progress with this issue?

Kind regards,
Katja

@katja.suvajac,

The linked ticket ID PDFNET-42579 is pending for the analysis and not resolved yet. We have logged an ETA request under the same ticket ID PDFNET-42579 and will let you know once a significant progress has been made in this regard.

I have the exact same problem. After conversion of a pdf that consists of scanned images to PDF/A the file is getting about 15 times bigger than the source file. This also happens in the newest release (18.3.0).

Source File: 7,29 MB
PDF/A 3u with Aspose PDF: 110 MB
PDF/A 3u with Adobe Acrobat DC: 7,35 MB

The same happens with files that did not consist of scanned images:

Source File: 50,6 KB
PDF/A 3u with Aspose PDF: 1,79 MB
PDF/A 3u with Adobe Acrobat DC: 146 KB

Is there any progress on this topic?

@joerg.kerschbaumer,

Kindly upload your source PDF documents to any free file sharer server, e.g. Google drive, and then send us the download URL. We will investigate your scenario in our environment and share our findings with you. Your response is awaited.

The linked ticket ID PDFNET-42579 is not resolved yet.

Sorry it took so long. I created a project that you can use to test it. If you execute the code you can see, that after the conversion to PDF/A the output file is about 118 MB large. The input file is only 7,42 MB in size. If i convert the same file with Adobe Acrobat DC the resulting file is about 7,49 MB in size.

Link

@joerg.kerschbaumer,

We managed to replicate the problem of large sized output PDF document. It has been logged under the ticket ID PDFNET-44521 in our bug tracking system. We have linked your post to this ticket and will keep you informed regarding any available updates.

Has there been any action on PDFNET-44521? Has it been resolved? If so, in what release? This same issue is happening in our environment for a large base of State Department users.

@kittlell

Thanks for your inquiry.

I regret to share that earlier logged issue is not yet resolved due to other pending issues in the queue. Please note that the issue was logged under free support model and has low priority unlike the paid support where issues have high priority and are resolved on urgent basis. However, we will definitely let you know as soon as we have some updates regarding its resolution. Please spare us little time.

We are sorry for the inconvenience.