We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PdfContentEditor.ExtractLink running forever for some PDF files

Hello. I’ve found that the PdfContentEditor.ExtractLink method is not working on some PDF files I’m trying to read. I have attached one of the problem files.
When I try to call ExtractLink on these files, the call never returns but it continues to use the CPU.
I’ve tried this with the PDF Kit versions 3.0 and 3.1 for .NET 2.0.
Thanks in advance.

Hello Derek,

We apologize for your inconvenience. I have tested the issue and I’m able to reproduce the same problem. I have logged it in our issue tracking system as PDFKITNET-5742. We will investigate this issue in detail and will keep you updated on the status of a correction.

Thank you for the reply. Please let me know a rough timeframe for delivering a fix whenever you have an idea.

My client is anxious to get a fix for this. Is there any estimate on how long it will take?

Hello Derek,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have contacted the development team, and soon they will be updating you with the ETA for the solution of this problem. We are sorry for the inconvenience that you are facing in this regard.

Hi,

This problem has been solved, we can provide you a vesion within two days.

BTW: The running forever problem is because our kit can not parse your pdf document correctly, and you should notice that your pdf document doesn't contain any links.

Great! Is this fixed in version 3.2? If not, please send me a fix as soon as possible.
Thanks.

Hi,

Yes, the fix is inculded in Aspose.Pdf.Kit v3.2. Please download and try it.

Thanks,

The new release appears to solve the problem.
Thank you very much.