Free Support Forum - aspose.com

PdfExportImagesFolder

Hi,


I’n trying to use the new version 9.3. I noticed that the save method and saveoptions have changed compared to 9.1.
I used to be able to specify the folder that’s used when converting images in the word template with the property SaveOptions.PdfExportImagesFolder. I cannot find that option any more. Could you explain the new way of specifying that folder? Or do you know the default location of that folder?

Best regards,
Chris Vrolijk

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. As you already know the legacy (old) method of PDF conversion was excluded from the latest version of Aspose.Words. PdfExportFloatingTables, PdfExportImagesFolder properties relate to legacy method of PDF conversion and do not have any effect in case of using direct Save method. So you should use the code like the following to convert your document to PDF:

doc.Save(@"Test\out.pdf");

Best regards,

Hi Andrey,

Thanks a lot for your quick reply.
I don’t understand your answer. In version 9.1 I used code like:
doc.SaveOptions.PdfExportImagesFolder = System.IO.Path.GetTempPath();
doc.SaveToPdf(0, doc.PageCount, resultfile, pdfoptions);

Now in 9.3 I use code like:
Aspose.Words.Saving.PdfSaveOptions pdfoptions = new Aspose.Words.Saving.PdfSaveOptions();
pdfoptions.SaveFormat = SaveFormat.Pdf;
pdfoptions.TextCompression = Aspose.Words.Saving.PdfTextCompression.Flate;
pdfoptions.JpegQuality = 100;
pdfoptions.EmbedTrueTypeFontsForAsciiChars = this.IncludeFontsInPDF;
doc.Save(resultfile, pdfoptions);

That’s OK, isn’t it ?

But I assume Aspose.Words is still using some directory to write temp files when converting images? I would like to know which directory that is, so I can set appropriate permissions. The problem I’m facing is that when running doc.Save from my ASP.Net application I get a System.Security.Exception: Request for the permission of type
‘System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089’ failed

That Exception is solved when I run my application pool as LocalSystem, which has all the permissions.

Could you please advice?

Best regards,
Chris Vrolijk

Hi Chris,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Direct method of PDF conversion does not require saving any intermediate files on disk, when you perform conversion to PDF.

Your problem might occur because Aspose.Words does not have permissions to read fonts, which are installed on your PC (C:\Windows\Fonts folder by default). So please make sure that your application has right to read from this folder. Fonts are necessary during converting to PDF.

Best regards,