We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Percentage Values from excel to Gridweb mismatch

Hi Team,

i have attached excel file for your reference kindly run it with aspose gridweb. Percentage values in excel is getting changed in Gridweb after importing into gridweb.After manually typing some values in GridWeb cell(%) the values is getting changes for excel and gridweb. Kindly check and reply at the earliest.

Regards,
Gawaskar.

Hi,


Thanks for the template file.

I tested your scenario and imported your file into GridWeb, it works fine. The percentage values in the first and second sheet are displayed fine and are same as MS Excel.

I used the following sample code to open your file into the GridWeb:
GridWeb1.WebWorksheets.ImportExcelFile(“e:\test2\Book1.xlsx”);

If you still find any issue, kindly do create a sample project and attach it here. Give us steps to reproduce the issue on our end. Also attach some screen shots for the problematic areas (Do not mix this issue with referenced formulas (for other worksheets) that you already posted into your other thread as we will fix it separately) comparing the GridWeb view with MS Excel view for your sheets of template file. It will help us to reproduce the issue on our end. We will check it soon.

Thank you.

Hi Team,

I’ve created sample project and screenshot for your reference.In Screenshot1 importing excel data into gridweb. after importing if we change any value say D5 cell i typed as 15.26% in the second screen shot it displaying as 1526.00% different value but in excel if i change it displaying 15.26% correctly.

Thanks & Regards,
Gawaskar.

Hi,


Thanks for the project.

I have tested your case and I am afraid, I could not find anything different than what MS Excel does. Aspose.Cells.GridWeb follows MS Excel standards and works the same way as MS Excel does.

I have checked your issue in both Excel and GridWeb. For your information, when you type as “15.26%” in D6 cell in the first worksheet and press enter in both Excel and GridWeb, it will retain as “15.26%” in the cell. But, when you type as “15.26”, it will be become “1526.00%” in both Excel and GridWeb which is normal behavior as we have already set “%” percentage number formatting to the cell(s), i.e. the formatted 15.26% value is actually equal to 0.1526…

Thanks for your understanding!

Thanks...!

Actuall in Excel file if u change the value in D6 as 15.26% or any value it remains as same (two values with two decimal value with % symbol) (15.26%) in excel, but if u change in Gredweb in D6 as 15.26 value is changes as 1526.00(its showing four values and with two decimal palces).

kindly help on this issue.

Thanks & Regards,

Gawaskar.

Hi,

gawaskar_n:

but if u change in Gredweb in D6 as 15.26 value is changes as 1526.00(its showing four values and with two decimal palces).


As I told you in my previous post that it works the same way MS Excel, for confirmation, I have created a video when performing the same task (i.e. select the value in D6 cell and replace it with "15.26" and press enter) in MS Excel manually. You will see it also gives "1526.00%" value same as GridWeb. I have attached the movie here for your reference.

Thanks for your understanding!
gawaskar_n:

Thanks...!

Actuall in Excel file if u change the value in D6 as 15.26% or any value it remains as same (two values with two decimal value with % symbol) (15.26%) in excel, but if u change in Gredweb in D6 as 15.26 value is changes as 1526.00(its showing four values and with two decimal palces).

kindly help on this issue.

Thanks & Regards,

Gawaskar.

Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

I have looked into your issue and found that Aspose.Cells for GridWeb is working fine.

If you enter value e.g 1526 in Ms-Excel, then it will show 152600.00%.

The same occurs in Aspose.Cells for GridWeb. Please see the following screenshot for your reference. Please see sections highlighted with red markings inside it.

So, it is not a bug.

Screenshot:

Thanks For sharing Shreenshot.

In above thread mention as cell value 1526 then it will show as 152600.00%. For This 152600.00% showing in Grid web cell it has to display as 1526.00%. Gridweb have to be userfriendly as like Excel Fromatting with Percentage in cell level.

If your are not clear my issue kindly lets have a quick call with your Aspose Development Team to discuss on this.

Regards,

Gawaskar.

gawaskar_n:

Thanks For sharing Shreenshot.

In above thread mention as cell value 1526 then it will show as 152600.00%. For This 152600.00% showing in Grid web cell it has to display as 1526.00%. Gridweb have to be userfriendly as like Excel Fromatting with Percentage in cell level.

If your are not clear my issue kindly lets have a quick call with your Aspose Development Team to discuss on this.

Regards,

Gawaskar.

Hi,

Thanks for your clarification.

We have found this issue and logged it in our database with the issue id: CELLSNET-41261.

Although both Ms-Excel and GridWeb shows cell correctly as 152600.00%.

However, your problem lies when cell is edited. While editing cell, GridWeb shows the number as 1526 but Ms-Excel shows it as 152600%.

Below is a screenshot that illustrates this issue.

Screenshot:

Hi Team,


Thanks for identifying this issue.

Kindly provide the updated dll after fixing this percentage issue in Aspose GridWeb at the earliest.

Regards,
Gawaskar.

Hi,


We are working over your issue and hopefully the feature would be included in the next upcoming fix (that is scheduled to be release in the next week hopefully). Once the fix it available we will provide it here.

Thank you.
gawaskar_n:
Hi Team,

Thanks for identifying this issue.

Kindly provide the updated dll after fixing this percentage issue in Aspose GridWeb at the earliest.

Regards,
Gawaskar.
Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

We have fixed this issue now.

Please download and use the latest fix: Aspose.Cells for GridWeb v2.7.13.2004 and let us know your feedback.

Hi Team,

Still we are facing the issue in percentage inside Gridweb. Kindly help me on this issue.

Regards,
Gawaskar.

gawaskar_n:
Hi Team,

Still we are facing the issue in percentage inside Gridweb. Kindly help me on this issue.

Regards,
Gawaskar.
Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

I have tested your issue with the latest fix and found that your issue is fixed. Please see the following screenshot for your reference.

As you can see, cell is showing as 5.2% while editing it. So it is a correct behavior. Could you please recheck it and let me know your feedback.

Screenshot:

Hi All,

Still we are facing the issue in percentage after updating the latest dll inside our project, Might be we are missing some piece of part in latest dll.

Could you please post the sample project and with test data in Excel file, so that i can test and change it accordingly.

Thanks & Regards,
Gawaskar.

gawaskar_n:
Hi All,

Still we are facing the issue in percentage after updating the latest dll inside our project, Might be we are missing some piece of part in latest dll.

Could you please post the sample project and with test data in Excel file, so that i can test and change it accordingly.

Thanks & Regards,
Gawaskar.
Hi,

It seems, you have updated dll but not the acw_client directory. Delete your existing acw_client directory and replace with the new one which is given in this fix: Aspose.Cells for GridWeb v2.7.13.2004

Hi Team,


We have uploaded sample project and still we are facing the percentage issue.

We have added the new dll and acw_client as per your suggestion.

Kindly test this project and give your comments.

Regards,
Gawaskar.

Hi,

Thanks for your sample project.

Your settings are quite ok. I was able to run your project and I found no issue at my system. Please see the screenshot below for your reference.

It seems, this issue is occurring on your system because of different browsers. Could you please share your browsers information and screenshots?. I would log your feedback and reopen this issue.

Screenshot:

Thanks for your update…


Can you please try deleting the values in particular cell with percentage symbol and then if you type new value say (15.20) then its goes to like 1520.00% in gridweb cell. but without deleting percentage symbol inside the gridweb cell its working good.


We are using Internet Explorer 8, and mozilla firefox with latest version.

Regards,
Gawaskar.

Hi,

Thanks for your feedback and input.

We are able to observe this issue by following your steps.

Once, the value is deleted entirely and new value is inserted, it displays the same behavior as you stated. Without deleting, the GridWeb behaves correctly.

We have reopened this issue. Once, this issue is fixed or we have any other update for you, we will let you know asap.