We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Porblem with SQL Server 2012

Hi,


What i have done doesn’t seem to work so i need urgent support…


Step 1 - Opened the C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies folder.

Step 2 - Copyed Aspose.Pdf.ReportingServices.dll (downloaded from here and extracted from bin\ReportViewer2010) to that folder.

Step 3 - Register Aspose.Pdf for Reporting Services as a rendering extension. For that i’ve open the file C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies</font> RSReportDesigner.config and added the following lines into the element:
<Extension Name=“APPDF” Type=“Aspose.Pdf.ReportingServices.Renderer,Aspose.Pdf.ReportingServices”/>

Step 4 - Give Aspose.Pdf for Reporting Services permissions to execute. To do this, i’ve located RSPreviewPolicy.config in the folder, open
it and added the following as the last item in the second to outer element:

<CodeGroup class=“UnionCodeGroup” version=“1” PermissionSetName=“FullTrust”
Name=“Aspose.Pdf_for_Reporting_Services” Description=“This code group grants full trust to the AP4SSRS assembly.”>
<IMembershipCondition class=“StrongNameMembershipCondition” version=“1” PublicKeyBlob=“00240000048000009400000006020000002400005253413100040000010001000734cc24bfcebd7aa8c6e2bf8af5c2b95c7a7e6092abb60d68a7d9efde285cf7dce7f354b44cf3064e8ad85bddfe405ad1e51855d9a1367c15cb34529988feeee0c3279caecdb6dfd7f94c5364d2bd282c4f93493d56d33df36f97da8fd71bb7dc4b0e7f1428b926291cdea7cec1085aa9cc0f6771e4fc2f5772603eee3afaaa” />

Step 5
i follow this post so i located  PreviewProcessingService.exe.config in the folder, open it and added the 
folowing element

<dependentAssembly><o:p></o:p>

<assemblyIdentity name=Microsoft.ReportingServices.ProcessingCore publicKeyToken="89845dcd8080cc91"culture=neutral/><o:p></o:p>

<bindingRedirect oldVersion=10.0.0.0 newVersion=11.0.0.0/><o:p></o:p>

</dependentAssembly><o:p></o:p>

<dependentAssembly><o:p></o:p>

<assemblyIdentity name=Microsoft.ReportingServices.Interfaces publicKeyToken=89845dcd8080cc91 culture=neutral/><o:p></o:p>

<bindingRedirect oldVersion=10.0.0.0 newVersion=11.0.0.0/><o:p></o:p>

</dependentAssembly>

Step 7 :License Aspose.Pdf for Reporting Services
i have a temporary License Aspose.pdf for Reporting Services.
copied the file to C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies folder.
i follow this post
Step 6 - Reloaded Visual Studio.

Result :
I have this error :

The report
preview worker process failed to start before the timeout expired. Retry
preview after reopening the project. If the problem persists, adjust the
PreviewProcessingServiceStartupTimeoutSeconds value in the
RSReportDesigner.config file.
(Microsoft.ReportingServices.Designer)<o:p></o:p>

I have Microsoft Windows Server 2012 R2.

SQL Server 2012.

Microsoft SQL Server Management
Studio 11.0.6567.0<o:p></o:p>

Microsoft Analysis Services Client Tools 11.0.6567.0<o:p></o:p>

Microsoft Data Access Components (MDAC)
6.3.9600.17415<o:p></o:p>

Microsoft
MSXML 3.0 6.0 <o:p></o:p>

Microsoft Internet
Explorer 9.11.9600.18538<o:p></o:p>

Microsoft .NET
Framework 4.0.30319.42000<o:p></o:p>

Operating System 6.3.9600


NEED YOUR HELP!!


Regards,

I have also adjust the Timeout to 150 seconds but still the same problem.


Hi There,


Thanks for contacting support.

We are looking into the details which you have shared and will get back to you shortly. Please be patient.


Best Regards,

Hi Hafedh,


Thanks for contacting support.

I have tried replicating the issue but as per my observations, the input .RDL file is generated using FILTERS_MSRCM database, so can you please share the datasource or re-generate .RDL file using Adventure Works database, so that we can again try replicating the issue in our environment. We are sorry for this inconvenience.

Hi Nayyer,


please find join the new RDL with connexion to Adventure Works database.
It’s very urgent for me to solve this situation…
Thanks.

Hi Hafedh,


Thanks for sharing the sample report. We are working on testing the scenario and will keep you updated with our findings.
Hi Hafedh,

Thanks for using our API's.

I have tested the scenario and have observed that report is not rendering the contents in ReportServer preview and also I am unable to see export options. For the sake of correction, I have logged it as PDFRS-33540 in our issue tracking system. We will further look into the details of this problem and will keep you posted on the status of correction. Please be patient and spare us little time. We are sorry for this inconvenience.

Any news ?

it’s been 2 weeks now !!

Hi Hafedh,


Thanks for your patience.

As we recently have noticed earlier reported issue, so its pending for review and is not yet resolved. However the product team will surely consider investigating/fixing it as per development schedule and as soon as we have some definite updates regarding its resolution, we will let you know. Please be patient and spare us little time. We are sorry for this delay and inconvenience.

Hello,

I work with Hafedh and we are waiting for the answerd of Aspose proctuct team.
Please can you send us as soon as possible the result of your investigation/fixing.


Thank you.

Best regard,

Hi There,


Thanks for your inquiry. I have checked the status of the issue and I am sorry that it is still pending for review. As shared earlier, that we just notified relevant team about the issue and they have been busy in resolving other issues in the queue, reported prior to yours. I am sure that they will soon start an initial investigation for your issue as per their development schedule. We really appreciate your patience in this regard. We will certainly let you know as soon as we have some definite updates about its resolution.

Please be patient and spare us a little time. We are sorry for the inconvenience.


Best Regards,

Hi,


Any news about this issue?


Hi Hafedh,


Thanks for your inquiry.

I am afraid that currently logged issue is not resolved yet as development team has been is in resolving providing/fixes for other reported issues in the queue. We have intimated the product team about your concerns and depending upon their development schedule, they will plan an investigation accordingly.

We greatly appreciate your patience and comprehension in this regard. Please spare us little time. We are sorry for the inconvenience.


Best Regards,

Hi,

Can We have a deadline at which you can provide an answer to the problem encountered.

Regards,
Jean-Yves AKA

Hi Jyves,


Thanks for your patience.

As shared earlier by Fahad, the issue is pending for review and unless the development team has figured out the actual reasons behind this problem, we may not be able to estimate the effort required and therefore its quite difficult to determine the tentative timelines regarding its resolution. However, as soon as we have some definite updates, we will let you know.

Hi,

Can we have news about this issue ?

Best Regards,

@boumessouerhafedh

Thanks for your inquiry.

I am afraid that earlier logged issue is not yet resolved due to low priority and other pending issues in the queue. However, we have escalated the issue priority to next level and as soon as we have some updates regarding resolution progress, we will share with you. Your patience and comprehension is greatly appreciated. Please spare us little time.

We are sorry for the inconvenience.