Free Support Forum - aspose.com

Powerpoint to pdf in webapplication

Hi,


I am trying to convert powerpoint files to pdf with the following code:
PdfOptions pso = new PdfOptions();
pso.setCompliance(PdfCompliance.PdfA1b);

if (sourceFile.toLowerCase().endsWith(“x”)) {
Presentation pres = new Presentation(sourceFile);
pres.save(outPutFile, 1, pso);
} else {
PresentationEx presx = new PresentationEx(sourceFile);
presx.save(outPutFile, 1, pso);
}
this works perfect from eclipse, but when i run it within my jboss environment i am getting an error:
"java.lang.Exception: java.lang.NoClassDefFoundError: com/aspose/slides/c/a/aH (wrong name: com/aspose/slides/c/a/ah)"

It appears that both classes are part of the library, how come the code is not able to load the correct one?

Hi Suijker,


I have tried to observe the issue shared by you. First of all, I suggest you to please try using Aspose.Slides for Java 7.1.1 on your end. There is no issue in your code sample. What I feel is that probably you are not able to reference the jar file properly. Can you please try using the latest version on your end and share the sample application along with sample presentation with us. Please also share the complete environment details where by you are trying to use Aspose.Slides on your end. I will try to help you further in this regard.

Many Thanks,

LS,

I am using Aspose.Slides library version 7.1.1

on jboss 6.0.0.

Running on windows 7

Regards,

Jasper

Hi Jasper,


Thanks for sharing the information. Can you please share the sample presentation that you have used to reproduce the issue on your end.

Many Thanks,

Attached the pptx i used

Hi Suijker,


I am sorry for the delayed response but I have been working over your requirement. I like to share that the issue is on JBosss end due to Aspose.Slides obfuscation. I have created an issue with ID SLIDESJAVA-33795 in our issue tracking system to further investigate and resolve the issue if some thing can be done on Aspose.Slides end. We will share the feedback with you as soon as it will be shared by our development team.

Many Thanks,

Hi Suijker,


I would also suggest you to please visit this web link for your kind reference as it may help you to find some quick workaround on JBoss end.

Many Thanks,

Just as a note, i have the same (kind of) problems when converting with excel files

Hi Suijker,


I like to share that you need to consult Aspose.Cells forum for excel files related issues. Please share if I may help you further in Aspose.Slides related inquiries.

Many Thanks,

The issues you have found earlier (filed as SLIDESJAVA-33795) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.