PPT file corruption after usage of ExternalWorkbookPath or SetExternalWorkbook


#1

Hi Aspose team,

if you run attached project you will see that new document is saved with 0 bytes and during save error:

Unhandled Exception: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
at Aspose.Slides. .(Single , Double , Int32 , ? )
at Aspose.Slides .( ? )
at Aspose.Slides.Charts.Chart.wghxc7kq5bpewg3z9kl55dukble7gh7h??( ? , ?? , InterruptionToken )
at Aspose.Slides. ? .(Shape )
at Aspose.Slides. ? .(IShape )
at Aspose.Slides. ? .(GroupShape )
at Aspose.Slides ? . ? )
at Aspose.Slides ? . ? )
at Aspose.Slides. ? . ? )
at Aspose.Slides. ? . ()
at Aspose.Slides. ? .()
at Aspose.Slides. ? .(Stream , ISaveOptions )
at Aspose.Slides.Presentation.Save(Stream stream, SaveFormat format, ISaveOptions options)
at Aspose.Slides.Presentation.Save(String fname, SaveFormat format)

happens.
I tried also SetExternalWorkbook and got same issue. Saving of PPTX files works.
In my application users are opening file and making changes which are saved to same file so at the end Aspose.Slides is corrupting PPT documents by saving them with 0 length.

Can this be checked with priority due to criticality?

Thanks,
Oliver

PPT_Corruption.zip (231.3 KB)


#2

@droli,

Can you please share which Aspose.Slide version you are using on your end.


#3

I used latest 19.9 but you can see that if you start my project with sample code :wink:


#4

@droli,

I have worked with source files and sample code shared by you and have been able to observe the issue. A ticket with ID SLIDESNET-41480 has been created in our issue tracking system to further investigate issue in detail. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.


#5

Hi Adnan,

I understand that you have policy first come first served but considering that this bug is destroying files can you please check with colleagues when fix will be available?

Thanks,
Oliver


#6

I just tried also with 19.10 and still the same problem. Updated file is saved with 0 bytes.

Based on my code you can see where the problem is and put try…catch to avoid that file cannot be saved and ended with 0 bytes. Of course, real fix is needed but better error handling will at least keep files without damages.

Thx


#7

@droli,

I have noted this problem in our issue tracking system and like to inform that we are working on this and will get back to you with good news soon.


#8

Sorry for pushing but any news here? We had to stop usage of our application to avoid that we loose documents due to this bug and this is now burning really bad.


#9

@droli,

I like to inform that in Aspose.Slides forum the issues are selected for investigation on first come first serve basis. Also the first priority for scheduling and resolution is given to paid Enterprise and priority support customers. Then Aspose.Slides normal or free support customers issues are scheduled and resolved on first come and first come serve basis. I will share the further information with you as soon as the issue will be resolved. I request for your patience.


#10

Paid ticket opened :slight_smile:


#11

@droli,

Thank you.