Free Support Forum - aspose.com

Ppt to pdf NullpointerExcepion on Linux

In our company we use Aspose Slides for Java running on Red Hat Enterprise 5.
Version: 2.5.0 (licensed).
On Windows pdf generation works well, but on the server we still get (as when trying with 2.3.0 and 2.4.0) the

2011-05-09 12:48:45,129 ERROR [STDERR] Caused by: java.lang.NullPointerException
2011-05-09 12:48:45,129 ERROR [STDERR] at com.aspose.slides.obfuscated.lq.for(SourceFile:208)
2011-05-09 12:48:45,129 ERROR [STDERR] at com.aspose.slides.obfuscated.ka.(SourceFile:21)
2011-05-09 12:48:45,129 ERROR [STDERR] at com.aspose.slides.obfuscated.lq.(SourceFile:20)
2011-05-09 12:48:45,129 ERROR [STDERR] at com.aspose.slides.obfuscated.ka.do(SourceFile:42)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.lf.do(SourceFile:44)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.lm.do(SourceFile:33)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ku.do(SourceFile:90)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ld.do(SourceFile:94)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.hs.do(SourceFile:38)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ho.do(SourceFile:12)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.hf.do(SourceFile:12)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ho.do(SourceFile:12)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.id.do(SourceFile:83)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ld.do(SourceFile:55)
2011-05-09 12:48:45,130 ERROR [STDERR] at com.aspose.slides.obfuscated.ahi.do(SourceFile:57)
2011-05-09 12:48:45,130 ERROR [STDERR] … 125 more


Additional Information:
Our server is running -naturally- without X Server.

Please advice to a way to circumvent the problem described.

Hi Oliver,

Thanks for your interest in Aspose.Slides.

I like to share that in order to carry out further investigation on our end we need the source presentation for our investigation. Can you please share the source presentation for necessary investigation.

Thanks and Regards,

Hi,
didn’t I upload a presentation two weeks ago?
I will retry and hope for help from your side.
Saving that presentation as pdf works on windows, but not on my headless (no X server) linux.

Best regards
Oliver

Hi Oliver,

I have worked with the presentation file shared by you and have been able to observe the issue while generating the PDF in Linux environment. An issue with ID 27349 has been created in our issue tracking system to further investigate and resolve the issue. We will share the further information with you once shared by our development team.

Thanks and Regards,

Hi Oliver,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Our development team has investigated the issue by setting up Red Hat Linux 5 environment and it has been observed that you are missing True Type fonts that have been used in your presentation.

Actually, by default the True Type fonts package is not installed In RHEL5 environment and you may need install these. You may please visit this web link which is the solution for your issue. Please perform the following steps and then try exporting presentation to PDF.

  1. Install the software needed
  2. Download the specs to build the RPM
  3. Build the RPM
    • rpmbuild -ba msttcorefonts-2.0-1.spec
  4. Install the RPM
    • rpm -ivh /usr/src/redhat/RPMS/noarch/msttcorefonts-2.0-1.noarch.rpm

For your kind reference, I have also shared the generated PDF. Please share the feedback with us, if you still feel any issue.

Thanks and Regards,