We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Presentation save method pass in slide number array contains 0 will cause exception

the save method for presentation pass in slide numbers will throw exception as long as slide number start from 0.
com.aspose.slides.exceptions.ArgumentOutOfRangeException: ‘slides’ array contains 0 slide position, which is not present in the presentaiton.

@Test
public void testSlideStartsFrom_0() throws IOException {
IPresentation pres = new Presentation(“BasicSlideStartFromNumber0.pptx”);
int[] slideNumbers = {0};
pres.save(“testPptxToPdf.pptx”, slideNumbers, SaveFormat.Pptx);
}

@oraspose,

I have observed the information shared by you and request you to please provide the source presentation file with us reproducing the issue on your end. Please also try using Aspose.Slides for .NET 17.7.0 on your end as well before sharing further information with us.

BasicSlideStartFromNumber0.zip (23.1 KB)

we have tried aspose.slides for java version 17.7, the problems exist

@oraspose,

I have worked with source code and presentation file shared by you using Aspose.Slides for Java 17.7 and have been able to observe the issue. A ticket with ID SLIDESJAVA-36545 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.

We are sorry for your inconvenience,

any progress on this ?

@oraspose,

I have verified the issue status from our issue tracking system and regret to share that at present the issue is still unresolved and we will share good news with you as soon as the issue will be fixed.