Print area Zone_d_impression problem


#1

I have version 3.7.0.0 of ASPOSE.Cells. We generate an Excel file with 4 WorkSheets. We set a print area on each sheet using this code.

ws.PageSetup.PrintArea = "A1:M11"
ws.PageSetup.FitToPagesTall = 1
ws.PageSetup.FitToPagesWide = 1
ws.PageSetup.Orientation = PageOrientationType.Landscape
ws.PageSetup.PaperSize = PaperSizeType.PaperLetter
ws.PageSetup.CenterHorizontally = True

When we open the xls file we get an error message asking to rename the print area Zone_d_impression.
We want to get rid of that message. How can we do it ?

We have asp.net 1.1, VS2003, ASPOSE 3.7.0.0
Excel 2000 french, Excel 2003 french.
OS is W2K Pro English.

Please help
s1harmonie@hotmail.com


#2

Is it possible to post your output file here? Or please send it to nanjing@aspose.com. Thank you.


#3

Here is the file.

Thank-you


#4

Please try to open this attached file to see if this problem still ocurrs in your French Excel.


#5

Hi,

Yes it still occurs. The problem is still there.

Thank-you


#6

I can open your file and my file in English MS Excel without any problem.

Could you use French MS Excel in your machine to open this file and save it? Then please post this resaved file here.

And if possible, please also post the screenshot of this error. Thank you.


#7

Hi,

When you open the file again, it ask for a new name for the print_area, if you dont give one it will not open. So to save it here, i would have to rename the print area and the problem would not happen again. Here is a screenshot.


#8

I had met this problem before. It's caused by conflicts between language version of MS Excel and OS. Could you please manually create an Excel file with print_area settings in your French MS Excel? And please post this file here.

Thank you very much.


#9

Here is a working manually created file.

Thank-you


#10

Please try to open this file.


#11

Hi,

This file does not cause any problem when I open it.

Where do you think the problem coming from ?

Thank-you


#12

It's caused by language and local settings. The language of output file is French and your locale is Canada, right?

Now Aspose.Cells gets these information from OS. However, the OS settings may be different with end users. I will add properties to let you set language and locale in MS Excel. I will give you a new fix about this in a few days.


#13

Please try this attached fix.

Before calling Excel.Save method, please add two lines of code:

excel.Language = CountryCode.France
excel.Region = CountryCode.Canada


#14

We will try that.

I will post again on this thread if we encounter the problem again.

Thank-you for you time